Security Feed
OpenSSH `sshd` auth bypass via `crypt()` failure handling with `*` hashes and long passwords
On Linux systems using musl libc with PAM disabled, sshd password auth can be bypassed when musl crypt() returns ”*” on failure (e.g., SHA512 crypt() password length >256 bytes), colliding with ”*” used as a locked password field. This can make logins incorrectly ACCEPTED for ”*” accounts. Upgrade to OpenSSH 10.6p2 to mitigate.
CVE-2026-118131 – GnuPG for Windows ProgramData DACL inheritance allows config injection and code execution
GnuPG for Windows 2.5.21 inherits insecure default DACLs on C:ProgramData, allowing BUILTINUsers to create arbitrary subdirs. A low-priv attacker can precreate the expected GnuPG config directory and drop malicious config files consumed by GnuPG components, leading to code execution in the victim user’s security context. Mitigate by fixing C:ProgramData ACLs and upgrade to GnuPG 2.5.24.
Airbyte Connector Builder manifest class injection allows command execution even with unsafe code disabled
**Airbyte `
CVE-2026-119084 – Amazon Redshift JDBC Driver unsafe reflection enables RCE via connection URL/profile
Unsafe reflection in amazon-redshift-jdbc-driver < 2.3.0 allows reflection injection when an attacker can influence the JDBC connection URL parameters or the AWS credentials profile handling. If a suitable class exists on the application classpath, the attacker can trigger arbitrary code execution in the application context. Upgrade to 2.3.0+ to mitigate.
CVE-2026-119179 – MongoDB Node.js Driver connection pool desync leaks cross-request data
MongoDB Node.js Driver connection management can return a pooled socket to the pool while prior response data is still pending, causing reply/request mismatches when optional client-side operation timeout is enabled. Remote unauthenticated app users can trigger cross-request data disclosure and incorrect results/failed ops. Affects 6.11.0
CVE-2026-119977 – WordPress Core TOCTOU in full-package upgrades enables unauthenticated RCE
Unauthenticated RCE in WordPress core 4.7–7.1.3 via a TOCTOU race during full-package core upgrades. Predictable, web-accessible staging paths used by the upgrader allow an attacker to execute server-side code during the upgrade window. Cisa confirms active exploitation of this CVE. Upgrade to patched versions 7.1.4, 7.0.8, 6.9.11, or 4.7.39 to mitigate.











